Contributors mailing list archives

Browse archives


Re: New repos proposal

Camptocamp SA, Simone Orsi
- 14/06/2022 11:04:39
Hi Daniel,

On Tue, Jun 14, 2022 at 9:41 AM Daniel Reis <> wrote:

I've been using server-backend to implement API tools.
Here is the WIP of what I've been working recently:
Would be nice to understand what kind of requirements you are targeting, and compare to mine.

Would be nice to have a good description there ;)
After a quick look I'd say it contains a lot of duplicated things.
Many of those concepts are already implemented in the edi repo and other repos.
But this is out of scope I think.
A new repo could be a good idea. 
Note that not all APIs are Web,
The repo I propose is specifically for WEB API. I'd like to avoid to have yet a catch-them-all repo to host all the possible modules that might have to deal w/ any kind of "api".
(This is also in line w/ what we discussed at board level regarding reducing the scope of the repos whenever possible).
I also found the need to integrate with FTP/SFTP, EDI style.

There's already an integration between EDI and storage repo ;)

Sounds like a good idea.
What about "pwa-tools", similar to "server-tools"

Well, since the main scope is to offer a way to build pwa apps I'd prefer "-builder" or "-maker" or smth like that (all in all will be similar to "mis-builder").

Thanks to you. Hope I cleared my POV :)



On 14/06/22 08:22, Simone Orsi wrote:
Hi all,

I'd like to propose 2 new repos:

1. web-api : collect modules to expose or deal with web api (eg: custom management for routes and endpoints, generic tools to handle calls to ext api, etc).

2. pwa-builder : collect modules that allow to create and manage standalone PWA apps. As many of you know I split the core of the shopfloor wms app some time ago and this core now allows you to create - potentially - any kind of PWA app w/ its backend (based on rest services) and frontend tools (VueJS based). This core is now in OCA/wms but that's not really the right place. The name is not adequate too (shopfloor_base) so I think I'm going to rename it to pwa_core or pwa_builder or something similar.

I'd say each of them should have its own PSC but maybe having one is fine too.

Looking fwd to your feedback.


Simone Orsi

Full stack Python web developer, Odoo specialist, Odoo Community Board Member, in love with open source.

Post to:


M: +351 919 991 307
A: Avenida da República 3000, Estoril Office B, #34

Post to:

Simone Orsi

Full stack Python web developer, Odoo specialist, Odoo Community Board Member, in love with open source.